Re: ASP not setup correctly?
by "Kathy Evans" <kje(at)vendetta.co.uk>
|
| Date: |
Fri, 15 Jun 2001 08:51:42 +0100 |
| To: |
"David Jemison" <pithon(at)lifeinkorea.com>, "Hwg-Servers \(E-mail\)" <hwg-servers(at)hwg.org> |
| References: |
lifeinkorea |
| |
todo: View
Thread,
Original
|
|
I hope this is just an MDAC version error, make sure that they have the
correct version of MDAC for (current is 2.6). Don't try to change
individual components, you need the whole set if its a Windows OS.
Sometimes this error is caused by the interaction of a third party
component (such as, er, Cold fusion in advanced security mode or crystal
reports web server) or anything else altering the registry so that the
registry key permissions or entries for MDAC are for older versions or
point to the wrong dlls. You can find the ODBC.ini entry in the registry
(with regedt32) and check the permissions on the DSN entries. Reinstall
MDAC (or if its WIn2k, you have to reinstall the OS), if this is the
problem (so I suggest considering Win2k sp1 as it contains MDAC 2.5
sp1).
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Kathy
http://www.vendetta.co.uk
DNRC Minister for Useful but Irritating Information and Trivia
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
----- Original Message -----
From: "David Jemison" <pithon(at)lifeinkorea.com>
To: <hwg-servers(at)hwg.org>
Sent: 15 June 2001 01:48
Subject: ASP not setup correctly?
> We recently started hosting one of our client's sites. (They ran to
use
> a week after their hosting contract expired and asked us to begin
> hosting right away.)
>
> Their site is done with Active Server Pages, while we use Cold Fusion
> for our sites. Their site worked fine on our local test server, so we
> uploaded all the files to our main server (setup almost exactly the
same
> as our test server). However, whenever we try to open a database
> conenction, we get the following error:
> error '800401f9'
> Error in the DLL
> /test/test.asp, line 13
>
> All line 13 does is open a database connection (lines 12-13 follow):
> Set ktest = Server.CreateObject ("ADODB.Connection")
> ktest.Open "Korea"
>
> We've been using this datasource for months with no problem, and it
> works fine on our local server.
>
> I've had no luck getting help from an ASP newsgroup or searching the
> Microsoft site, other than one "helpful" response that there's an
error
> in a DLL somewhere. Duh!
>
> Does anyone know why this error happens on one machine but not the
> other, and (more importantly) how to fix it?
>
> We've already had to spend several days recoding parts of their site
> into Cold Fusion to get most of it working. But we also want to host
> other client sites in ASP in the future.
>
> --
> David Jemison
> http://www.lifeinkorea.com
> http://www.lifeinasia.com
>
HWG: hwg-servers mailing list archives,
maintained by Webmasters @ IWA
This page is part of a preserved archive of archives.hwg.org. The site is no longer active and its content is not maintained. For enquiries about this archive, write to archive(at)iwanet.org.